Update to Wordpress 5.5 and jquery-migrate

Hi,

I’ve seen a lot of sites having troubles with the new wordpress version due to the jquery-migrate library. I’ve checked my website and I’ve seen that your theme is using it. So I want to know if there is any problem migrating to the new version of wordpress before doing it.

Anyway it’s suposed that wordpress will no longer support it so, is there any expectations of getting an update for the Sparkling theme without the jquery-migrate lib?

Thanks in advance.

Hey there

yet, there was no problem reported, you can update it to the latest version and just in case you may use this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/

Thanks

Thanks for your answer,

Anyway, as far as I know, this plugin is a temporal fix for the problem (it will no longer be supported on version 5.7). So, are you working on rewrite the theme to delete de dependency on this js lib?

I don’t want to have problems with the website in the future so, please, let me know if should I start working to migrate the website to another theme or the theme will be adapted.

Thanks.

Hey there

yes, I agree with you, this is a temporary solution and we will update theme soon with the necessary fixes :slight_smile: