Travelify: Submenus do not work in Internet Explorer IE10

Hello Support,

submenus are not shown in IE with mouse-over effect. I entered the following css, but this shows ALL submenus at the same time.

#main-nav li:hover ul {
opacity: 1;
display: block !important;
}

Look at https://sandbox.ping-pongline.de/

Maybe you have a solution.

See also topic: https://colorlib.com/wp/forums/topic/my-menues-dont-work-any-more-in-internet-explorer-2/

Best regards.
Dirk

Hi there

Hope you are having a good day and thank you for your question :slight_smile:

Kindly confirm, did you try this code?

.main-navigation .menu > li:hover > ul {
opacity: 1;
transform: translate3d(0, 0px, 0);
-webkit-transform: translate3d(0, 0px, 0);
-moz-transform: translate3d(0, 0px, 0);
visibility: visible;
}
.main-navigation .menu>li>ul li:hover>a {
opacity: 1;
}

Please add it in Appearance > customize > additionall css

Thanks!
Colorlib Support Team

Hi,

this code was allready published in the other post.

And yes, I tried this, but it does not work because there is no css-class called “.main-navigation” in Travelify-theme.

Best regards.
Dirk

Hey Dirk

It works normally for me in IE: https://prnt.sc/trok7i

Is this fixed already or how come?

Hey Noda,

I tried some css, but currently no satisfying solution.

Did you try IE also on this site: https://colorlib.com/travelify/
Here IE is also not working.

Hi Dirk

What do you mean by not satisfying by the solution? :slight_smile: is this not working?

Yes, I know about it and its already reported