Menu not showing on mobile (unite theme) / dropdown not working

Hi,

I’m pretty new to making website so would highly appreciate a little guidance! The issue is my menu headers are not showing up at all in the mobile version. There’s only a dropdown and even when clicked, its not working. The site is: tiomanisland . guide (no space in btwn the period).

Thank you!

Hi there,

Could you check if you plugins are causing the issue by disabling all plugin except the ones the theme requires in appearance \ install plugins.

Especially if you have a minification or caching plugin disable it for now.
Let us know if that exposes the cause of the issue.

Thanks.

Hi,

Thank you for your response. I deactivated the plug-ins, but still didn’t help…I wonder if perhaps the problem is because the size of the menu pages is too big and so it overflows (doesn’t show at all)? I had a slightly similar issue with links not working before on mobile and fixed it by adding "style=“float:left” thanks to the site below. However, I am not savvy enough to check the code to see if thats the case.

http://ayeshalshukri.co.uk/dev/bugfix-for-wordpress-colorlib-unite-theme-links-not-clickable-on-mobile/

Any further thoughts/guidance highly appreciated!

Hello ,

Please use this plugin to check your WordPress version, it should be version 7.2 or higher:
https://wordpress.org/plugins/wordpress-php-info/

Best Regards,
Support

Hi,

Thank you for that guidance. I have checked the Wordpress PHP and updated it to 7.2. However, the issue still remains.

Regards,
Dmitri

Hi there
Please deactivate all third party plugins and try again your problem, most probably this I conflict with third-party plugins.
Once you deactivate all plugins please check your problem again, if the problem is gone then this means it was a plugin conflict. Now, start activating plugins one by one and same time repeat your problem until your problem appears again, now you know which plugin was in conflict Thanks!
Colorlib Support Team

Hi Noda,

Thank you for that. However, I already deactivated all the plugins as was suggested earlier and it didn’t help. This was with PHP 7.0. Do you believe the result may be different with PHP 7.2? If so, I can try again.

Thank you.

Hello there,

Please use this plugin to backup your WordPress then have your host update you to 7.2:

https://wordpress.org/plugins/updraftplus/

Best Regards,
Support

Thank you, but I already backed it up and updated to 7.2 when it was suggested yesterday, as can be seen above. I have also previously deactivated the plug-ins and that did not help.

Is there anything else that could be the problem? My initial thought as mentioned above is that its an “overflow” issue for lack of a better word. But I don’t know how to check this out.

Any other ideas / insights would be much appreciated.

Regards,

Let me check this out, please use this plugin to create temporary access for us, its automatic login link and does not requires sharing your admin details. here is How To guide. at the and don’t forget about  “Set as private reply” at the bottom of the message box  
use your email address in the plugin

Hi Noda,

Really appreciate you taking the time. Please see link below. Also, if not too much trouble (as you’ll already be in the site), would it be possible to take a very brief look at why the menu custom links such as “Must Read” and “Other Destinations” aren’t showing the dropdown – even on desktop. I wonder if it may be related. If its an issue, no worries at all, first things first!

http://tiomanisland.guide/wp-admin/?wtlwp_token=a263cd321c11449af146364d7d7a2d51

Hi @student4site

Menu works normally when i deactivated all your third-party plugins, :slight_smile:
You can do the same, and then start activating plugins one by one to discover problematic plugin

Thank you for checking. However, when i check the site on my mobile it’s still having the same issues of not showing the menu, nor the drop down. May I confirm that it worked for you on your mobile? If not, could you please confirm on your mobile that the menu is showing up?

Please see screenshot below.

Hello there,

@Noda said the menu worked on mobile when the plugins were deactivated so there is a plugin causing this issue. You need to disable the plugins individually to find the problem plugin.

Best Regards,
Support

I just went through it all again, and found the plug-in that didn’t work! So weird that it didn’t find this initially when I deactivated them all. Thank you very much for your patience and bearing with my ignorant questions.

Cheers,
Dmitri

Hello there,

There are no ignorant questions, these kinds of issues take some time to figure out is all.
Please feel free to contact us again in the future regarding any other issues.

Best Regards,
Support