Main Menu Items Not Dropping Down

Hello,

I guess I should have waited to upgrade to new Newspaper-X theme until site was fully up and running. Now can’t seem to unscrew myself.

We really liked the theme itself in combination with Modula Galleries for our travel / photo blog, and were doing our “no longer a sandbox” adjustments, starting to add actual content, and now are stuck on two issues: Menus and Modula Galleries are now seemingly both broken. Sigh.

Long story short, I upgraded to Newspaper X version 1.3.1 today and now all my main navigation menus are just appearing as static links instead of cascading menus with sub-items. I’ve tried purging cache on all devices (computer browsers, Android and iPhone / iPad), but no joy. Any advice appreciated.

The Problem Child: https://milestowander.com/

Here is a screen shot of what is not happening on main page (or any page):

null

And the configuration screen in WP…green top menu items display, pink sub-menu items do not:

They were working perfectly before I ran the updates. Thanks in advance for any words of wisdom.

John

Hey there

I just checked it and your website looks normal for me, did you managed to fix this problem?

Hi Noda,

Thanks for your response. Love this theme and want to make it work as it was before the upgrade we ran yesterday.

No, it is still displaying only static titles on the top menu bar. No drop down menus matching the menus we had in place prior to upgrade, and which are reflected in the screen shot I included. The menus were links to categories from the category tree we were building. I have added another image below to clarify. Only the top level displays on primary menu in template now. Before the upgrade it, rolling over the first link showed the cascading sub-menu items for navigation.

My first thought was caching, but we have no caching in operation that I am aware of, and manually cleared it as we normally would after a version updated. The devices we have are Mac OS X, Android and iOS (iPad and iPhone). The same thing appears on all platforms. We have a router that does not content cache connected to a very fast connection with no upstream proxy.

I tried turning off all security measures, but that did not help, so I reactivated them.

The only custom CSS I used was to fix the issue we had with external links embedded in posts not working on phones or tablets. I have not tried taking that out, as I need embedded links to function on small devices. Here that is:

article { z-index:1; }
.post, article.page { z-index:1; }
@media (max-width: 768px){
#secondary {
    clear: both;
}
}

So, I remain puzzled. It’s a sandbox still, but we were ready to plug actual content in this weekend. Figured we can’t travel right now, so why not finish our travel blog? :wink: I would be happy to give you access to WP instance if desired.

Regards,

John

These Menus Not Displaying

I see that I missed the edit time window to fix link to settings. Here it is.

These Menu Items Not Displaying in Nav Menu

Hello,

Still not able to view our site’s navigation drop down menus normally since the update of the Newspaper X theme. Still baffled. If anyone has a moment, would appreciate some feedback. Have tried six different devices (Android, iOS, Mac OS X) with multiple browsers on each, and from different networks. No caching plug ins installed that I can find.

Thanks,

John

hi John

Sorry for the delay, please provide access details in a private reply and steps to replicate your problem, I will take a closer look

Best regards

Noda,

I am not sure what else I can add to the description in my posts, and those screenshots.

In short:

  1. Our sandbox WP instance using Newspaper-X theme (https://milestowander.com) - which we were getting ready to load with real content - had a normally functioning series of CSS-driven cascading menus and sub-menus in the usual place just below the top bar in web browser and large device views. Each menu item is a category page.

  2. Since upgrading Newspaper-X, however, these appear with only the top level item displaying, and do not cascade to review sub-menu items.

  3. Not using caching plug ins (so far as we know!), and have cleared browser and device caches as best we can.

Let me know if I have left something important out, or if you want me to create a Temporary Log in URL for you.

Love the theme, and appreciate the help.

Regards,

John

Hi John

So, shortly, your submenus are not appearing, right? please note, this problem is already reported and we are waiting for the fix, also, please consider this problem is happening in browsers like IE and safari not in other browsers

Sorry once again :slight_smile:

please note, this problem is already reported and we are waiting for the fix, also, please consider this problem is happening in browsers like IE and safari not in other browsers

Hi Noda,

You are correct that submenus are not appearing, but we are experiencing this issue with Firefox and Chrome browsers on Mac OS X, iOS devices (iPhone and iPad) and Android Firefox and Chrome. We don’t use IE or Safari at all.

Thanks, and please post or contact when a fix is found. We will use another theme for now, but would rather use Newspaper-X.

Regards,

John

Hi John

Please take my apologies on this and thank you for understanding, once we release a new update I will refresh this ticket

Have a nice day