Problem with WP 4.6

Hi,

I have a Problem with the Pinbin Theme after installing WordPress Version 4.6

All of my posts are vertical aligned to the right side.

http://www.klarerblick.de

Before WP 4.6 everything was ok.
I deactivated all my plugins, but the Problem is still there.
I also tried this solution: http://cristarta.com/jquery-masonry-breaks-pinbin-theme-fix/
Didn’t work.

Please help.

Thx
Greeting
Helmut

Hi,

I solved the problem by commenting some lines out in wp-content/themes/pinbin/js/functions.js.

BEFORE


/* General Pinbin Functions
================================================== */

// masonry customization
jQuery(document).ready(function($) {
	var post_area = $('#post-area');
	post_area.imagesLoaded(function(){
		post_area.masonry({
		// options…
		isAnimated: true,
		isFitWidth: true,
		animationOptions: {
			duration: 400,
			easing: 'linear',
			queue: false
		}
	});
	});
});

AFTER


/* General Pinbin Functions
================================================== */

// masonry customization
jQuery(document).ready(function($) {
	var post_area = $('#post-area');
	post_area.imagesLoaded(function(){
		post_area.masonry({
		// options…
		/*
		isAnimated: true,
		isFitWidth: true,
		animationOptions: {
			duration: 400,
			easing: 'linear',
			queue: false
		}
		*/
	});
	});
});

Love the theme …

Greetings
Helmut

Hi Helmut,

Awesome great to see you got that solved.

You can also resolve this issue by using Pinbin child theme shared in the following topic.

https://colorlib.com/wp/forums/topic/posts-dont-slide-well-into-eachother-since-wp-4-6

Have a fantastic day!

Cheers,
Movin

Hi Helmut,

Thanks for your post. Had the same problem and now with your help it’s gone…
But the main page is now left aligned (was centered). As I can see the main page of your site is centered.
How did you get it?

Thanks,
Leo

Hi Leo,

I solved the problem with Helmuts indications but also found my homepage not centered anymore, my solution for that was
/* centreren homepage */
#post-area {
margin: 0 auto !important;
}

instead of

/* centreren homepage */
#post-area {
margin: 0 auto !important;
width: 100% !important;
}

so remove width: 100%;

Kind regards from Danielle

Hi Danielle,

Thank you very much for your prompt response!

Unfortunately this trick didn’t help me ;(
Still looking for solution…

Kind regards,
Leo

@Leo2014 Could you please share me your site URL where it’s happening so that i can troubleshoot it?