Featured image not being picked up when sharing posts on social media (Facebook)

Hi,

I’ve now put together two posts and shared them on social media (Facebook) and every time I’m needing to manually add an image to the post (which I can’t do if I’m sharing the link in a comment) because Facebook is not picking up the featured image. I’ve run the FB debugger and getting the following warnings:

Inferred Property
The ‘og:image’ property should be explicitly provided, even if a value can be inferred from other tags.
Missing Properties
The following required properties are missing: og:url, og:type, og:title, og:image, og:description, fb:app_id

The whole layout of the link preview in Facebook looks ‘off’ and not how I would expect it to look.

Here are the links to the two posts:

http://clairebrummell.com/social-justice/what-harm/
http://clairebrummell.com/social-justice/big-changes-and-im-sorry/

And I’ll attach a screenshot of how they look when you post in Facebook.

Can you help please? I need to be able to share effectively on social media, and I really don’t want to have to redesign with another theme to get it to work! :slight_smile:

Thanks,

Claire

Hello,

I hope you are doing well today.

You try using the following plugin to fix this:

https://es.wordpress.org/plugins/facebook-thumb-fixer/

I would recommend that you install Yoast SEO and enable the open graph meta data for Facebook:
https://wordpress.org/plugins/wordpress-seo/

Here is a guide to help you with this:
https://themeskills.com/fix-featured-image-not-showing-facebook-sharing-wordpress-posts/

Best Regards,
Support