Anchor links not working properly

Hi! First of all, thank you very much for this amazing theme. It was easy and great to use it.

However, I need a little help with anchor links because no matter what I try, I can’t seem to make them work properly. I couldn’t find anything on the forum that worked for my problem.

I added custom links to my menu (I had to put www because they didn’t work without it) and first 3 are working fine, but last 3 are not jumping to the right place on the page on the mobile version. On my laptop, last 3 are sometimes working perfectly but sometimes also jumping on the wrong place. Whatever I try, I can’t make them work as they should.

Also, I tried to change the ID of every section so my links would be in Croatian. I changed them in Theme Editor - sections / every section ID. I also changed them all in every css (#ID of the section) but unfortunately, every section lost its css properties and the whole page looked horrible so I had to rename them back.
Can you please help me with that too?

Website is www.solux.hr.

Thank you very very much!

Hey there

Which one is not working? I just tried your website and all the menu links are working just fine for me?

Hi, thank you for your reply!

On mobile devices the last 3 links are not working as they should - “Cjenik”, “Galerija” and “Kontakt”.
They are not scrolling to the heading of the section or they are on a completely wrong section.

Those same 3 links are also sometimes not working in desktop version - when you click two or three times on the same link it sometimes scrolls to the heading, sometimes somewhere in the middle and sometimes to the end of the section.

Hi! Is there any solution to this problem?
Thank you for your help

Same problem occurs on two of my websites: www.jmetertraining.nl and www.testautomation.study. Could you please provide help?

Kind regards,

Benny van Wijngaarden

The menu doesn’t work in Illdy demo page too.

https://demo.colorlib.com/illdy/

Hey there

I’m sorry guys, the problem is reported, it will be fixed in the upcoming update of the theme:

Sorry for inconvenience

Hi,
The anchor links still don’t works on my website (and they still don’t work in the demo page too) but I see some updates of the theme lately, I updated my theme each time but no improvement for the anchor links.
Will they be in the next update ?

Thank you

Hi

Sorry, but I cant say when next update will be released :frowning:

I have the same issue with my website https://facialesthetics.co.uk - none of the anchors are working since the theme upgrade in Feb/March 2021 time. Is there a workaround on this?
(IE: Botox Wakefield - Non-Surgical Solutions | Facial Esthetics by Erica Wright and /#projects)

hi @beseen

Sorry, but yet there is no solution for problem :frowning: